Machine-generated analysis · WAYSCloud LLM
PowerSYSTEM Center versions up to 5.29.x, 6.2.x, and 7.1.x are vulnerable to SQL injection and improper authorization.
Context
Subnet Solutions PowerSYSTEM Center is a software platform used in critical manufacturing and energy sectors, deployed worldwide. The advisory reports that low-privileged authenticated users can execute unauthorized SQL commands and access administrator-level resources in the listed versions. The vulnerabilities carry a CVSS v3 score of 9.
Operator considerations
Check: Verify the installed PowerSYSTEM Center version and patch level.
Patch: Upgrade 2024 releases to PowerSYSTEM Center 2026 Update 1.1 and 2020 releases to Update 30.
Log: Monitor user activity records for signs of unauthorized access.
Isolate: Disable browser developer tools for PowerSYSTEM Center Client Access Server users.
Successful exploitation of these vulnerabilities could allow an attacker to execute unauthorized SQL commands and gain access to unauthorized resources.
The following versions of Subnet Solutions PowerSYSTEM Center are affected:
PowerSYSTEM Center 2020 =6.0.x|=7.0.x|=6.0.x|
Read the full advisory on CISA →